Release Note of BV_Analyzer Ver.0812

Major changes from Ver.0807

1. The additions in analytical functions - Available for MiCAM ULTIMA, MiCAM02, MiCAM01 data

(1-1)

[Wave of ROI/Line] the additional function

 The function for outputting waveforms information of all pixels located on the specified area or the line was added.

(1-2)

[APD Function] the improved function

  The window was modified so that user can operate easier than before.
  The function for calculating conduction velocity on an activation map in the APD function.

(1-3)

[Making Correlation Map] the function for making the correlation coefficient map

  New Function  Calculate the correlation coefficient between a waveform on a selected pixel and waveforms on all pixels, making the map indicating strength of correlation.  Enable to display an additional line.

(1-4)

[Making Activation Map] the additional function

  The function for making a graph of activation time on the specified line on the activation map function was added.

(1-5)

[Making tiled image] the additional function

  The option of the user to set the frame number and the range of tile indication.

(1-6)

The additional function for renaming files in BV_Viewer      

  Enable to rename data files.  It is convenient for Ultima data files because all related files are renamed automatically.

(1-7)

[Display Statistical Analysis Window] the improved function

  [Export CSV] was added.  The displayed waveforms was extended to eight pixels.

(1-8)

HNI-AVI/LSM files can be loaded in the BV_Ana.

  Enable to load a [Hni AVI] file acquired/saved by HNI-1250.
  Enable to load a LSM files which are made by Zeiss' products.  Available only for monochrome file.
  A part of the analysis functions was revised in order to accept various size of file.

(1-9)

The editing of sampling time

  New Function  The function for inputting sampling time to the data which has no sampling time such as TIFF/AVI/LSM files.

(1-10)

[Cell Count] the additional function

  New Function  This function changes a gray image to black/white image, and then the number of black areas is counted.  Use it to count the cell.

(1-11)

[Control] tab page was improved.

    The checkboxes in the [show option] area in the previous version were moved to the sub window which can be shown with the [show option] button.

(1-12)

Others  

  Fixed a bug that the BV_Ana aborts when pushing the [Movie] button just after the BV_Ana starts up and then, some data is loaded on the canvas.
  The [Conduction Velocity] and [Statistic] sub windows were changed to the modeless mode so that user can operate the main window/canvas without closing sub windows.
  Fixed a bug that an error occurs when loading a TIFF file (16bit-Gray Scale).

2. Additions in Acquisition Function (Available to MiCAM02 only)

(2-1)

Extension of the number of maximum frames
(for MiCAM02 with 1Gbyte memoryj

  New Function  Enable to extend the number of maximum frames acquired with MiCAM02 with PGbyte memory.

(2-2)

Trouble correction when EXE is restarted

  When BV_Ana.exe was restarted from MiCAM02 for CE, trouble that the Acquisition tab page was not displayed occurred, and this was revised.


1. The analysis function(MiCAM Ultima/MiCAM01/MiCAM02)

(1-1) [Wave Of ROI/Line]  The additional function

●New function for outputting each waveform data of all pixels on a line/in an area which are specified with WaveOfROI in a CSV file

●This new function can be used by pushing the [Save CSV(each)] button in the [Wave of ROI/Line] window. The [Wave of ROI/Line] window can be opened from [Analyze]-[Display window for Wave ROI/Line] on the main menu or on the tool bar. Use this function after displaying waveforms on the window by pushing the [Disp Wave] button.
"Averaged" waveform data of all pixels on a line/in an area which are specified with WaveOfROI can be outputted by the [Save CSV(average)] button.

An example of CSV file exported from the [Save CSV(each)] button

(1-2) [APD] The additional function

●The window was modified so that user can operate easier than before.  The function for calculating conduction velocity on an activation map between two points was added.

●Select data on the canvas and click [Cardio]-[Display Window for APD]. 

Attention
(1) Correct data with mBleachingn or mDrift Removen in the [Calculation] tab.
(2) The process of a data with [Wave-Filter] in the [Control] tab takes time, so it is recommended to filter a data with [Spatial Filter] or [HPF/LPF] in the [Calculation] tab in order to remove noise.
(3) Pixels on which differential data are displayed with color on the canvas can be used for APD analysis. Select suitable value of threshold and frame number.

●Execute the [Display Window for APD], then the box below can be appeared in order to ask user if the calculation of derivative is needed or not. When selecting mYesn, the default setting of activation time is [maximal dV/dt].  When selecting [No], the default setting is [maximal amplituden, and it is not able to select mmaximal dV/dtn.  Since the calculation of derivative takes time, select [No] if it is not necessary. 

●The [Show APD Map] window and the map in default setting are displayed as below. This map can be drawn using this process.

●How to display the map

(0) Change the gain of waveforms.  Set the [Select wave gain].

(1) Set the base line in the [Select base line setting].  The calculation of both maximum and minimum value is needed, so it is minimum value

        ①  Select [Auto], base line is minimum value.
        ②  Select [Manual setting of base line range], enable to limit the range.
            The gray area is displayed on the top waveform.  Set the both start and end lines by dragging the mouse.
        ③  Select [Min], it is minimum value in the specified range.  Select mMeann, it is mean value in the specified range.

(2)  ④  Set the calculation of Activation Time
            [maximal dV/dt] F  Multiply first derivation to waveform and at the point of maximum value of differentiation result
            [half-maximal amplitude]  F  At the point of value of imaximum value{baselinej/2
            [maximal amplitude] F  At the point of the maximum value of the waveform
           The time that is shown by green dotted line is the calculated activation time on the waveform figure.

(3)  ⑤  Input [Repolarization Time(%)]
        When input value is β, the repolarization time is the value shown as below.
           (maximum value-baseline)*(100-)/100 + baseline

(4)     Click [Redraw APD Map], recreate the map figure with a (1) - (3) setting condition.

      Switch the setting in the [APD Map Option] section, the setting is reflected on the Map figure. 

  Check the box of [Contour line], the contour line is displayed on the Map.

  Check the box of [Map Control], the green area shows the time range of activation map and the orange area shows the time range of repolarization map on the top waveform.

  Check the [Cursor On] box, the points are showed on the three maps.

  When [Color bar] is off, map is displayed with black and white gradation up to 256 steps. When [Color bar] is on, map is displayed with 256 gradation colors.  The 256 colors, that is used in default, is the same as that used for the color bar on the canvas.

  Click the [Load CSV File] button, select the CSV file used for color table.

Check the [Conduction Velocity] box, the conduction velocity is displayed.  The velocity is from the black cursor to the red cursor.

  Input absolute size of width and height of acquisition image on [X] and [Y] in the [Filed of View] section. The measurement unit is mm.

Conduction Velocity calculation
Conduction Velocity = Dist(p1,p2) / (Act Time(p2)-Act Time(p1))
Dist(p1,p2) is the distance between p1 and p2 (mm).
Act Time(p) is the sampling time (ActivationFrm*msec) at point P.
Activation time follows the selected conditions in [Activation mark point] section.

       [Zoom]   Change the magnification of map display.

      ⑮[Save APD Map]  Save the map figure.
          if the file extension is bmp/jpg FSave the image of map figure.
                  When the [Conduction Velocity] is on, both black and red cursors are displayed.
          if the file extension is csv FSave the numerical value of the map figure in the csv format.
                  Export numerical values used as activation time, repolarization time and APD time on all pixels.
                  The unit of each value is frame number. Therefore,   when user calculates actual time from exported value, multiply sampling time to each exported value.              

Changing the gain for color mapping
By clicking [▲][▼] next to each map figure, the maximum value and the minimum value of the mapping can be changed.
  At the first start, both maximum and minimum time regarding each activation time, repolarization time and APD map are automatically calculated, the total range between maximum and minimum time are allocated with 256 colors on the map. The time range of mapping is changeable with [▲][▼], but it is not able to set over maximum time and under minimum time.  The 256 colors are in the table of color bar on the canvas.  The range of mapping is displayed on the top of waveform. Activation time is shown in green, and repolarization map is shown in orange.  Click [▲][▼] synchronizes with the change. The lattice display as shown in green and orange represents the range of between the maximum time and the minimum time.

(5) The automatic calculation time is changeable by manual operation.  Click [Modify...by manual], the box as shown below is displayed.

Change the coordinates of pixel.  Specify x and y coordinates in [A][B]. 

The activation time line(green dotted line) and the repolarization time line (red dotted line)indicates the time calculated automatically.  Set both dotted lines to proper position with mouse drag.  Both green and red solid lines are in the manual setting positions.  Click [set] button and the manual setting information is displayed in the [E] section.      

Click the [Apply to Map] button, the manual settings is reflected on the map figure.

Click the [All Save CSV] button, all of manual setting points are saved in a CSV format file
  Click the [Load CSV] button, the file can be readout. This setting can be reloaded by clicking the [Load CSV] button, selecting a CSV file and        clicking the [Apply to Map] button to reflect it.

Click the [Redraw APD Map]button on the main box, the manual settings are cleared.

 

(6)  ⑰  Click the [Canvas setting reload] button when the setting of [Control] page such as [Start]/[End]frame and [Threshold] are changed.
    

● Process for making a map

Make three maps for all pixel data with the process as written below.
(1) Pixels that are not over the setting frame threshold on canvas, the time of activation, repolarization and APD are not calculated.  The background image is displayed in the map.


(2) Select the maximum value and the baseline  on the waveform under display.(The minimum is the baseline.)

(3) Calculation of activation map
          Select the activation mark from three modes.
            [point of maximal dV/dt] F Multiply first derivation to waveform and at the point of maximum value of differentiation result.
            [point of half-maximal amplitude]  F  At the point of value of imaximum value{baselinej/2
            [point of maximal amplitude] F  At the point of the maximum value of the waveform. Find the minimum activation time and maximum activation time in processing pixels, and then the each pixel in the range is displayed by 256 kindfs color.

(4) Calculation of repolarization map
           (maximum value-baseline)*(100-)/100 + minimum value    =numerical value at the range of 1% to 100%
    Find the minimum repolarization time and maximum repolarization time in the processing pixels, and then the each pixel in the range is displayed by 256 gradation color.

(5) Calculation of APD map   APD = repolarization mark - activation mark  
    Find the minimum APD time and the maximum APD time in processing pixels, and then the each pixel in the range is displayed by 256 gradation color.

(1-3) The function for making correlation coefficient map

●This function is to calculate the correlation coefficient between a selected waveform and all waveforms, and to make the map indicating strength of correlation.

●Select the data on the canvas, and click either [Analyze]-[Display window for Correlation Map] on the maim menu or  on the tool bar.  The [Correlation of wave form] box as shown below is displayed.

●Select the waveform
Select the number of waveforms which are used for calculation of correlation with waveforms of all pixels in the ①
(The maximum is three).  Drag a cursor on the image and set it at the proper position.

●Make the correlation coefficient map
The calculation processing of the correlation coefficient is done by clicking [CreateMap]②, and other Windows opens, and the map figure as shown below is displayed.  A color chart shows points beyond the threshold of the correlation coefficient.

●Change the detailed setting of the map figure.
Click the [ReDraw] button ⑩ after changing various setting in the [(4) Map Control] in order to change the map.

(AttentionjThe calculation of the correlation coefficient is needed again when the selected waveform is changed, and click the [CreateMap] button again.  This cannot be reflected only by [ReDraw] button.

●Change the image size of the map figure.
Click the [ReDraw] button after selecting the magnification of [Zoom]③.

●The transparent indication of the map figure
[Transparent]④ is on and click the [ReDraw] button in order to display a background image transparently.

●Display pixels that have correlation coefficients over threshold with single color.
Select the [Gradation Color] button ⑦ and select threshold percentage from the [Single] on the [Threshold]⑧ area.  Then click the [ReDraw] button.  Display pixels that have correlation coefficients over threshold with three colors (100%-90%
, 90%-70%, 70%-threshold%) based on percentage of correlation coefficients.

●Customize gradation color
Click the [Color Edit] button
in order to customize gradation color.  The color of three levels can be changed.   The [Setting of the color] box is displayed after clicking each color button.  With single color mode, only [Color 1] of each waveform is used.  Click the [ReDraw] button after customizing color in order to reflect it to the map figure.

The example of Gradation Color (Threshold=40%)

The example of Single Color (Threshold=50%)

●Save the map figure in a file
Save the map figure with either BMP or JPEG by clicking the [Save Map by BMP] button.
.

●Save the value of the correlation coefficient in a CSV file.
Click the [Save CSV]
button, save the information as shown below in a CSV file.
//-------------------------------------------------------
The number of pixels that corresponds within thee each range displayed on the right of the map figure.
(The total numbers are output for gradation
)
[REF1] The correlation coefficient of all pixels to waveforms(%) width column x height line
[REF2] The correlation coefficient of all pixels to waveforms(%) width column x height line
[REF3] The correlation coefficient of all pixels to waveforms (%) width column x height line
//----------------------------------------------------------------

The example of a CSV file

●The correlation coefficient is Pearsonfs product-moment correlation coefficient, is calculated with the following expression.

When the data line consisting of two sets of numerical value (x, \, y) = \{(x_{i}, \, y_{i})\}(i=1,2,\ldots,n)is given, the correlation coefficient is calculated as follows.

\frac{
\sum_{i=1}^{n}
(x_{i}-\bar{x})(y_{i}-\bar{y})
}{
\sqrt{\sum_{i=1}^n(x_{i}-\bar{x})^2}
\sqrt{\sum_{i=1}^n(y_{i}-\bar{y})^2}
}

However, \bar{x}, \bar{y} is an arithmetic mean of data x = {xi}, y = {yi} each.

(1-4) Additional function for activation map

●Select the data on the canvas and click the [Analyze]-[Display Window for Activation Map] on the main menu.
    The [Activation Map Show] box as shown below is displayed.  The function of (1) to (8) in the box is the same as before.
    (9) [Stripe Information] was added.  This is the function for displaying the graph indicating activation times of pixels on the specified line.

●(9)The [Stripe Information] is on.  The straight line is displayed on lower figure, and the [Stripe Information] box is appeared.  Both the starting point cursor (blue frame) and the terminal cursor (red frame) on this straight line are dragged, and moved to positions with which the graph is drawn.  This graph indicates distance (pixels) from starting point in horizontal axis, time (msec) at which data value is over the condition (Threshold+Peak/50% of Vmax-Vmin/None). This time is calculated as lapsed time from the frame set in [Strat Frm] on the [Control] tab page.

It is possible to input coordinates values of start/end pixels directly into and ②, respectively, and then, click .  
Click the [Export CSV] button on the graph box in order to output the value of the graph into a CSV file.



●(9)When clicking the [Help line Disp] button below the [Stripe Information] box, and additinal line which has some α angle to the straight line is displayed.
In order to specify the angle, input the angle into the ④[deg] next to the [Help line Disp] button. This additional line can move in parallel to the straight line with [][] button.  Click the [Help Line Clear] button to clear the additional line.

●Moreover, The [Stripe2] is on, the second straight line and graph can be displayed.  Set the position by dragging the starting point cursor (green square) and the terminal cursor (purple square) in the same way as Stripe1.  Enable to set it by the use of an additional line as shown in the figure below.  It is possible to input coordinates values of start/end pixels directly into and ②, respectively, and then, click .
Click the [Export CSV] button on the graph box in order to output the value of the graph into a CSV file.

(1-5) The additional function for tile display

●Select the data on the canvas, and select either the [Send BV_Sub] from the pop up menu displayed by right mouse click or  on the tool bar to open the other window for tile display.  This is the tile indication as for the time change of data.  The function of setting frames for tile indication by a user confirmed was added.
Click either the [View]-[Frame Setup] of main menu on the [BV_Analyze-Tile] window or  of tool bar, and the box as shown below is displayed.

●Select [Small size Image], [Large size Image], or [3D Image] from the view mode.

●Select frame display mode.
[Series Setup]
: Input the start frame and the number of skipped frames to display serial images every skipped frames.
[Free Setup]
: Can select the frames freely.  Input the number of frames for display in each line.

●Click [Apply] after completing the inputting.  The tile indication is changed.

●File output set mode and numerical value with [Save CSV]
   Read out the file next time by clicking [Load CSV].


(1-6) The additional function for renaming files in the BV_Viewer

The BV_Viewer is software for simple preview of the MiCAM data files.
  Either Click the [BV Viewer] button on the [File List] tab page or double click the "BV_Viewer.exe" to start up BV_Viewer.

●The [Rename] function was added to the pop up menu, which is displayed after selecting the file.
  Though the Ultima file is displayed under .rsh file name, several data files in the .rsh file are treated.  This function renames these file names collectively.

(1-7) Improvement of statistic function

●The [Statistic] from the [Analyze]-[Display Window for Statistic] on the main menu is the function for showing the moving average of waveforms (center line), and the line of the standard deviation of the error margin to the line, which is moving average of waveforms (center line), is displayed.

●The number of dislayed waveforms was increased to eight points, and the [Export CSV] button was added.  Click the [Export] button, and the box as shown left side is displayed.  Select type and shape of waveforms.  This function can output specified data in a CSV format.


(1-8) Loading HNI-AVI file and LSM file

●The [TIFF/LSM] and [HNI-AVI] are added in the [Format] list on the [File List] tab.
  The HNI-AVI file is the AVI file exported from HNI-1250Acq.exe (software for high-speed camera HNI-1250) .  The TIFF and LSM file have to be gray-scaled with the 16bit gray-scale or the 256 table.
  Please note that the BV_Ana cannot load all types of TIFF
, LSM, AVI files.      

●The following box is displayed when a file that has large image size and large number of frames is selected and as a result, the BV_Ana cannot keep memory space in a PC.  Specify the range of loaded frames by inputting the start/end frame number, and skipped step.  This box is displayed repeatedly until the BV_Ana can keep a enough memory space for data loading.

●Though it was assumed that other analysis features were able to correspond also with 400x400pixel or more along with reading TIFF/LSM/AVI file, from the problem at the memory acquisition and the processing speed, data up to the size of about 500x500pixel is recommended (previous version is up to 400x400pixel).  Moreover, at RMG file is saved, save the data after the calculation processing every time because some calculation processing functions (erase function reference change function)are not reproduced definitely.

(1-9) Editing of sampling time

●As for the file without sampling time information like the TIFF file and the LSM file, the sampling time is 1msec in default setting. 
  After selecting the data, click [Edit sampling time] on the pop up menu with right mouse click to adjust the sampling duration to an actual measurement value.   Input the right value on the box as shown below.

●(attentionjThis function only changes the sampling value of data.  As the data by the specified time is compressed and interpolated from current sampling time, use [change data size & time] on the pop up menu.

(1-10) New function for counting number of cells

● To use this function, only background image has to be shown, or the [Ps-Color] on the [Control] tab page has to be off so that data can be drawn with white and black gradation.   The function counts number of black area.

●Select the data on the canvas and then, select the [Analyze]-[Display Window for Cell Count] from the main menu.
  The [Cell Count] window is displayed as below.  At first, the same image as on the canvas is displayed on the [Cell Count] window as well.  

●The red graph next to the image is 0-255 gray scale histogram.
  Set the threshold to suitable value by dragging vertical black dotted line with a mouse. The threshold defines the balance of black and white.
  When a mouse is released, the extracted area is drawn wih blue color, and the counted number is displayed in the (1) area.

●The blue graph is displayed downward at the same time.  This is the histogram showing number of pixels in extracted blue area.  This can used for limiting the size of the extracted area by specifying the range of pixel numbers if necessary.   By dragging the mouse from the left to the right on a certain part of the histogram, the histogram is expanded.  The area, in which the number of pixels is within the range selected above, is shown with red color and the number of area is displayed in the (2) part.  It returns to the initial stage (whole chart) When a mouse is dragged from the right to the left on the histogram, it returns to the initial scale.   When the setting on the histogram is difficult, input the value in the [pix size] box in the (2) area and then, click the [Set] button.  The area, in which the number of pixels is within the specified range, is shown with red color and the number of counts is displayed in the (2) part.

●When the [overwrite on original image] is on, the extracted red are is overlapped on the same image on the canvas.  When the [overwrite on original image] is off, it is overlapped on the image made two values.

●When the gain and size of the image on the canvas is changed in the [Control] tab page by clicking [Canvas setting reload], the setting is reflected to the image of this box.  Do the process again from the beginning.

(1-11) Improvement in control tab pages

●The arrangement of each control on the [Control] tab page has been improved.

The main improvements are as follows.

The position of  [Time&Movie Control] and the position of [Image & Wave Appearance Control] are reversed.

The settings on the [Control] tab page are returned to initial default values with the [Return to default] button.

Save the current setting with [Save current setting] button.  It is applied to the next reading file without control informationiexcept *.gsd filej and the data newly acquired in MC02.
The setting is usually saved in C:\Brainvision\ini folder.

The box as shown left side is opened by [show option].  To previous version, the option flag that was on the [Control] tab page was brought together in this box.  The use of each flag is the same as previous version.



2. Additions in Acquisition Function (Available to MiCAM02 only)

(2-1) Extension of the number of maximum acquired frames (MiCAM02 with 1Gbyte memory)

●Extend the number of maximum acquisition frames in MiCAM02 with 1Gbyte memory by the following setting.
Install enough memory for the computer
(2GByte or more is recommended).  If the memory in the computer is not enough, the software shows an error.

●Only when the BV_Ana starts up at the first time, user needs to set the memory size in the [Memory Control] box, displayed from the [Utility]-[Memory Control] on the main menu.
    Users who use normal type of the MiCAM02 with 512GByte memory does not need this setting.

Select [1G] in the [MiCAM02 Memory Size] box when the MiCAM02 with 1Gbyte memory is used.  In this case, the [Use DoubleSide DIMM] has to be off.

Select either [512M] or [1G] in the [Max Memory Size / Data].

Click [OK] to close the box.

●After setting as above, the [maximum frame numbers that can be selected in the [Acquisition] tab page are changed as follows.

Pixel size

Number of maximum acquisition frames

MC02 with 1G

MC02 with 512M

  48 x 64

43680 frm

21840 frm

64 x 96

43680 frm

21840 frm

      128 x 192

10920 frm

5460 frm

256 x 384

2730 frm

1364 frm


●To see the outline of data over tens of thousands of frames promptly in [Movie], the [x100] was added to the select list of [Step] in [Time&Movie Control] on the [Control] tab page. Plays movie every 100 frames.