Release Note for BV_Ana Ver.1001

Updates from Ver.0909

1. Additions in analysis functions - Available for MiCAM ULTIMA, MiCAM02, MiCAM01 data

1-1 Extention of the [Wave Of ROI/Line] function Increases number of area, that user can specify with a polygon (ROI) or lines, to 8.
1-2 [Exciting pixel num wave chart] function New Function
Displays a waveform showing time course of number of pixels which are over threshold level.
1-3 [Extract ROI] function New Function
Specifies a polygon (ROI) and creates new data which have differential values only inside a specified ROI. This could be useful when data has noises on outside of ROI.
1-4 [Replace pixels with surrounding pixels] function New Function
Replaces differential value on a specified pixel with that on surrounding pixels, and creates new data. This could be useful when only one pixel has noise.
1-5 Improvement of the [Merge] function ・Fits maximum values of two waveforms.
・Overlaps only background images (without differential values). This allows user to overlap two data easier.
1-6 Improvement of the [Stripe] function ・Can specify a number of start frame and end frame on the [Stripe] map window.
・Waveform can be overlapped with other waveform displayed on the canvas when [wave chart at a frame] checkbox is selected.
1-7 Improvement of the [BV_Viewer] Exports data list, that is displayed on the center of the BV_Viewer, to CSV format by selecting the [File]-[Export data list with CSV format] on the main menu of the BV_Viewer.
1-8 Other improvements ・Fixed a bug that a color bar is not displayed when a tile image on the [BV_Sub] is saved in a BMP file. Makes a scale and shows discrimination of [dF] and [dF/Fmax] on a color bar.

・Shows discrimination of [dF] and [dF/Fmax] below each data on the canvas.

・Renames the [dF/F] on the [Calculation] page to the [dF/Fmax].

・In the [Wave FFT] function, displays a number of frequency (Hz) when a mouse cursor is over a FFT graph.

・Renames the [Delete frames] on the pop-up menu to the [Replace frames with surrounding frames].

2. Additions in Acquisition Function (Available only for MiCAM02)

2-1 Big fix of MiCAM02 USB interface Resolves an issue that monitor refresh rate is low on MiCAM02 USB interface version.
2-2 Bug fix for MiCAM02-dual camera Resolves an issue that there is an problem in a MiCAM02-dual camera mode, when two data is overlapped with the [horizontal] or [rotate of 180] selected.
2-3 Othes improvements During monitoring, can control software with keyboard operation.
Can select monitor refresh rate (interval) from 3 modes.

1. Additions in analysis functions - Available for MiCAM ULTIMA, MiCAM02, MiCAM01 data

(1-1) Extention of the [Wave Of ROI/Line] function

Specifies up to 8 objects with polygons or lines on an image, and displays averaged waveforms on pixels included in a specified . The followings are updated due to this extention of the function.

Starting
After selecting data on the canvas window, select the [View]-[Display Window for Wave of ROI/Line] from the main menu of the BV_Ana, or push the button so that the following [Wave of ROI/Line] window can be shown.

・Selecting wave number
Can display up to 8 waves. Click any line (indicating wave color) in the (2) "Select No." listbox. Selected number is displayed on the box next to the "(2) Select No.". Before proceeding with next step, make sure that either line is already selected.

・Selecting type of ROI (region of interest)
Selects type of ROI from line (pixels on a serial line) and polygon (pixels in poligonal region) in the (3). To change type of ROI (line/polygon), click on a line in the "(2) Select No." first and then, select "Line" or "Polygon" from the [Select Type] combobox.

・Specifying area for displaying averaged waves
To make a line or polygon, click on image continuously.
[Delete] key deletes proceding point. When "Line" is selected, click on image continuously and then, push the [Show Waves] button. When "Polygon" is selected, click on image continuously and click same point as firstly clicked point in order to close a polygon. After closing a polygon successfully, the [Show Waves] button will become active. Push the [Show Waves] button.

・Showing waves
Everytime after each object including line and polygon is specified, push the [Show Waves] button to show waves. Please note that this button becomes active after a polygon is not closed. After pushing the [Show Waves] button, "ON" is indicated on the [Use] column of the selected row in the (2) listbox.

・Moving line/polygon objects
Select object no. by clicking any row in the (2) listbox and push the [Move] button (the status of the [Move] button becomes "pushed"). After making a shape of mouse cursor [+] by mouse button down on an image, mouse-drag an object (line or polygon) to any position. Then, push the [Show Waves] button.
After dragging an object, the status of the [Move] button can be changed to normal. Only when the [Move] button is "pushed", an object can be moved.

・Copy and paste line/polygon objects
To copy line/polygon objects, select object no. for copying by clicking any row in the (2) listbox, and push the [Copy] button. Then, select object no. for pasting by clicking any row in the (2) listbox and push the [Paste] button. Push the [Move] button and mouse drag line/polygon objects to any position. Then, push the [Show Waves] button.

・Deleting line/polygon objects
Selects object no. for deleting from the (2) listbox and then, push the [Delete] button.

・Wave control
Adjusts wave gain and temporal filter, respectively in the "Gain" slide bar and "Tcnst-Filter" slide bar on the (6) area. Other options except wave gain and temporal filter are adapted from settings on the [Control] tab page.

・Correlation Calculation
The [Correlation] button makes a calculation for a correlation between two waves and, shows a correlation coefficient and a percentage of overlap between two waves.
Please note that a correlation calculation is done between wave of No.1 and selected wave. When status of the "Use" column on the No.1 row is not [ON], a correlation is not calculated even when pushing the [Correlation] button.


(1-2) [Exciting pixel num wave chart] function

・Displays a waveform showing time course of number of pixels that are over threshold level. The title, "over threshold", is on the lower part of the waveform. In order to show this waveform, select the [Exciting pixel num wave chart] menu from the pop-up menu.

(ATTN) With this graph shown on the canvas window, refresh rate for display tends to become very slow.

・Similarly to a waveform showing time course of changes in differential values, it is possible for users to change wave position on the canvas, expand/shorten range of data time and save data in AVI format.

・When the [display current data value] on the sub window opened from the [Show Option] button on the [Control] tab page is selected, total number of pixels at a current frame can be shown on an area next to a waveform.



(1-3) [Extract ROI] function

After selecting data on the canvas, execute the [Extract ROI] from the pop-up menu to open the window as below.

・(1) Selects maginification of image from the [Image Zoom] combobox.

・(2) In order to show waves for reference, drag green and orange points on an image. Corresponding to movements of points, waveforms can be redrawn.

・(3) Makes a poligon by mouse clicking on image. Please note that start point and end point should be same to close an polygon.

・When deleting a last point, press the [Delete] key. For clearing all points, push the [Clear] button.

・(4) After specifying a polygon, push the [Create New Data] to create new data on the canvas, and the window is closed. Differential values outside a specified polygon can be replaced with zero value.

・To save coordinates for selected points, push the [Save polygon data] button to save in a CSV file. To load information including coordinates and redraw a saved polygon, [push] the [Load polygon data].


(1-4) [Replace pixels with surrounding pixels] function

This function is for replacing differential value on a specified pixel with surrounding pixels, and creates new data.
After selecting data on the canvas, select the [Replace pixels with surrounding pixels] from the pop-up menu in order to open the following window.

・(1) Selects magnification of image from the [Image Zoom] combobox.

・(2) Drags a point to any position, or press the [▲][▼] buttons next to coordinates.

・(3) Selects either [Average] or [Median].

Wave A: Original waveform on a selected pixel.
Wave B: Waveform that is created from "averaged" value of surrounding pixels or "median" value among surrounding pixels.

・(4) If the above setting is OK, push the [Replace A with B OK] button. A value on a specified pixel is replaced with new value. A coordinates on which value is replaced can be listed in the [history (point)] box.
The above (1)-(4) process are repeatable.

・(5) Push the [New Data to Canvas] button to show new data on the canvas, and then this window is closed. When pushing the [Cancel] button on the lower part of the window, the window is closed without creating new data.

★ To undo process, select coordinate in the [history (point)] box, and then push the [Undo] button.

★ To save information about processed pixels (coordicates), push the [History Save] button and save data as CSV format.

★ The setting of the [Wave-Filter] on the [Control] tab page is not applied to data on this function.


(1-5) Improvement of the [Merge] function

Two functions are newly added to the [Merge] function, that can be executed from the [Analyze]-[Display window for Merge] on the main menu.

★ [Align maximum value of waves] checkbox
This checkbox is for fitting maximum values of two waveforms. Please note that baselines of two waveforms should be adjusted in almost same position. The [zero] checkbox on the [Control] tab page has to be OFF.

★ [Display only back image of merge data] checkbox
This checkbox is for overlapping only background images.
When this checkbox is ON, pseudo-color display for differential values is off and only background images can be drawn with color (red color for one data, and green color for another data). When pixels that have high intensities of brightness are overlapped, those pixels looks green. This allows user to overlap two data easier.


(1-6) Improvement of the [Stripe] function

New functions are newly added to the [Stripe] function, that can be executed from the [Analyze]-[Display window for Stripe] on the main menu. This function is for displaying time course of change in light intensity on a line/curve like the left figure.

● The [Stripe Map] window has new components, [Start] and [End] slide bars. This allows user to change a range of data frames on this window.

● When the [display wave chart at a frame] checkbox on the lower part of this window is selected, the sub window can be opened as below. This sub window also has new component, [Merge data] listbox. If data name is selected from this listbox, two waveforms are overlapped.

● This function is linked to dragging a blue dotted vertical line (indicating current frame), and [Movie] function on the [Control] tab page.

● From this version, start point has to be selected with right mouse button, and end point has to be selected with left mouse button for using the [Measure] function.



2. Additions in Acquisition Function (Available only for MiCAM02)

(2-1) Big fix of MiCAM02 USB interface

Resolves an issue that monitor refresh rate is low on MiCAM02 USB interface version.

(2-2) Bug fix for MiCAM02-dual camera

Resolves an issue that there is an problem in a MiCAM02-dual camera mode, when two data is overlapped with the [horizontal] or [rotate of 180] selected.


(2-3) Othes improvements

●During monitoring, can control software with keyboard operation.
Please note that the [acquisition window] should be active (selected) when keyboard operations are used.

The following key operations are available in the [acquisition window].
[Monitor]/[Stop][F2] key
[Bright/Gain][F3] key
[Auto Gain][F4] key
[Acquisition][F5] key

The following key operations are available in the [Monitor Brightness/Gain] window, that can be opened by the [Bright/Gain] button.
[↑] keySelects red vertical bar (offset)
[↓] key Selects green vertical bar (gain)
[←][→] keyMoves selected bar horizontally
[Enter] keyApplies gain and offset settings to monitor image
[Esc] keyCloses this window


● Can select monitor refresh rate (interval) from 3 modes (600msec/400msec/200msec). Default interval is 600 msec.

(ATTN1) If image sampling time is over 150 msec, this function is not available.

(ATTN2) When any mechanical shutter for a light soures is used, high refresh rate (especially 200msec) may damage a shutter. In this case, it is recommended to keep a shutteropen.