Release Note for BV_Ana Ver.1008

Updates from Ver.1001

1. Additions in analysis functions - Available for MiCAM ULTIMA, MiCAM02, MiCAM01 data

1-1 Improvement of FFT (Fast Fourier Transform) analysis function Can show Y-axis of a graph resulted from FFT analysis by using not only "amplitude", but "dB (decibel)" unit.
1-2 Data created from two data includes new information about position between two data Header information of data which is created from two data on the [Analyze]-[Display Window for Merge] function newly includes position information between two data, such as a gap, gain, rotation angle.
1-3 Improvement of function for reducing frame numbers every specified frames Can sequentially apply the [Toghether by step num]/[Extraction by step num ]/[MaxMin by step num] functions to selected data without closing window.
1-4 Improvement of [Conduction Velocity Function] Several fixes:
・Change expression of speed to "pix/frm" format.
・Add new mode for showing only angle of arrow (vector).
・Add new mode for displaying all arrows (vectors) in black color.
1-5 Can specify maximum value of a color bar and graduate a color bar. Valid for data that [dF/Fmax] calculation is applied to.
1-6 Others & Bug fixes (1) AVI export function for canvas window area
・Resolves an issue that default setting is not applied to selected range of frames (Wave start/end/step).

(2) Loading multi-TIFF data
・Resolves an issue that multi-TIFF data is loaded with wrong frame number and data which horizontal pixels does not have a multiple of 4 is not loaded correctly.

(3) [Extract over SD]
・Modifies so that setting can be saved/loaded in/from a registry.
・Modifies so that data in the [Extract over SD] box can be changed when data is changed on the canvas window.

(4) Modifies that both of time constant and cutoff frequency are displayed in the [LPF/HPF] window, opened from the [Calculation] tab page.

2. Additions in Acquisition Function (Available only for MiCAM02)

2-1 Changes external trigger mode so that interval time has priority over extrenal trigger input. Changes external trigger mode so that external trigger inputs are ignored during interval time in case that the [Start By] (external trigger) is selected in the [Trigger] area. After interval time finishes, external input can trigger data acquisition.
2-2 Data created by data process for two data newly includes position information between two data. Position information between data acquired with two camera are included in a header information of newly created data. This data can be created from [Dual Calculation Process] window opened from the [Acquisition] window.
2-3 Can rotate monitor image to 90 degrees. When the [vertical] checkbox is selected during monitoring, monitor image can be rotated to 90 degrees left and it can be vertical. This function is useful when MiCAM02 camera is set in a position of 90 degree rotation.

3. Function for receiving Ultima data (work together with MiCAM Ultima)

3-1 New function for receiving data from Ultima acquisition software. After data acquisition by using Ultima acquisition software, push the [Send BV_Ana] button. Consequently, acquired data can be transferred to BV_Ana.
BV_Ana receives data and displays it on the canvas window immediately.
3-2 Others & Bug fixes Fixed a bug that the Y-axis scale of external analog signal waveform is not correct (Y-axis scale only for MiCAM ULTIMA data was twice).

1. Additions in analysis functions - Available for MiCAM ULTIMA, MiCAM02, MiCAM01 data

(1-1) Improvement of FFT (Fast Fourier Transform) analysis function

● From this version, results from FFT analysis can be shown by using not only "amplitude", but with "dB (decibel)" format. "dB" format is applied by selecting the [dB] checkbox below the [Amplitude] radiobutton. Most dominant frequency (Pmax) among frequencies including DC components is used as reference line. The equation for calculating dB is the following.
      G = 10log10(Pk/Pmax)
With the [dB] checkbox off, "amplitude" format is used as well as previous version.


(1-2) Data created from two data includes new information about position between two data

● The "merge" function, which is executed from the [Analyze]-[Display Window for Merge] on the main menu (or button on the tool bar), can create new one data from two data by applying some calculation such as addition or division. And also, it is possible to adjust positions between two data in the [Adjust Control] area before creating new data. From this version, parameters that should be set int the [Adjust Control] area can be saved in a header file.

Parameters are listed in a header file like the right image.

(1-3) Improvement of function for reducing frame numbers every specified frames

● Can sequentially apply the [Toghether by step num]/[Extraction by step num]/[MaxMin by step num] functions to selected data on the canvas window.

● The left window is opened by selecting [Compression number of frames]-[Toghether by step num] from the pop-up menu. The [Target Data Name] listbox and [Update] button are added from this version. List of data which are loaded on the canvas window can be seen by clicking the [▼]. Select one data from the data list, and then push the [New Data Create] button in order to create new data which frame numbers are reduced (compressed). Without closing this window, it is possible to apply this process to other selected data.

● When new data is loaded on the canvas window after opening this window, the [Update] button can refresh list of data name.

● On the [Extraction by step num] and [MaxMin by step num] window, which are opened from the pop-up menu, the [Target Data Name] listbox and [Update] button were newly added as well as the [Toghether by step num] window.



(1-4) Improvement of [Conduction Velocity Function]

● Vectors displayed in a map on the [Conduction Velocity Vector] window indicates speed and direction of wave front. The faster speed is, the longer an arrow gets. Until previous verstion, there was a bug. This was fixed in this version.

● Changes expression of speed to "pix/frm" format. This speed can be seen on the bar at the lower position of the window.

● The [black line] checkbox and [angle only] checkbox are newly added in the [Vector Control] subwindow.
  [black line] checkbox: for displaying all arrows (vectors) in black color.
  [angle line] checkbox: for making lengths of all arrows (vector) same.

(1-5) Can specify maximum value of a color bar and graduate a color bar

● This is valid for data that [dF/Fmax] calculation is applied to.

● Open the [Setup display option] window from the [show option] button on the [Control] tab page.

● To display a color bar on the canvas window, select the [display the bar of color table] checkbox in the [Color table] area.

● Select the [fix the max(min) of table] checkbox in the [Color table] area, and then input number (percentage) of maximum value of a color bar, and push the [set] button next to the textbox.

● This function disables the [Img] bar and [Wave] bar in the [Gain] area on the [Control] tab page.

● A color bar on the canvas window is drawn using all of 256 colors and graduations. Black part indicates values below threshold level.



2. Additions in Acquisition Function (Available only for MiCAM02)

(2-1) Interval time and external trigger input

● External trigger inputs are ignored during specified interval time (sec) when the [Start by] (external trigger) is selected in the [Trigger] area on the [Acquisition] tab page.

The left figure shows that after pushing the [Acquisition] button, external trigger inputs are igonred for 6 seconds, then first acquisition can start by external trigger input.



(2-2) Data created by data process for two data newly includes position information between two data

● Calculation (subtraction/division) between two data that are acquired by dual camera system can be applied on the [Dual Calculation proc] window. This window can be opened by selecting the [Dual Calculation proc] checkbox on the [Acquisition] window. It is also possible to adjust positions between two data and to change coefficient for calculation. From this version, parameters that should be set in the [Dual Calculation proc] can be saved in a heade file.

Parameters are listed in a header file like the follwing image.

(2-3) Can rotate monitor image to 90 degrees.

● This function is useful when MiCAM02 camera is set in a position of 90 degree rotation.

● When the [vertical] checkbox is selected during monitoring, monitor image is rotated to 90 degrees left and it can become vertical.

● When data is acquired with the [vertical] checkbox ON, acquired data is displayed on the canvas window in a position of 90 degree rotation (vertically) as well as monitor image. This makes same result as data appied by rotation of 90 degrees left on the [Rotation of data] function from the pop-up menu.

● This can be also used when the [ROI Monitor] is selected. In the case that coordinates should be specified manually, note that users have to use coordinates of normal (before rotation) horizontal image.



3. Function for receiving Ultima data (work together with MiCAM Ultima)

(3-1) New function for receiving data from Ultima acquisition software without saving data in a file

Setting in BV_Ana
   Select the [File]-[Accept data from Ultima exp] in the main menu.
   If user does not do this operation before sending data from the Ultima acquisition software, an error message appers.
   After this setting, BV_Ana displays data that are sent from Ultima acquisition software. If data is acquired with dual camera mode, two data can be displayed separately.
   Save data in a file by pushing the [Save] button if needed.

Setting in Ultima acquisition software (valid in the version of 1002 or later)
  By pressing the [To BV_Ana] button (located below the [page selection area] at the left part of the Ultima acquisition sofware), acquired data is transferred to BV_Ana.
   Even after transferring data, Ultima acquisition software keeps data.
   In a sequencer script, "send_ana" command works for sending data to BV_Ana.

● When quitting Ultima acquisition software and then restarting it, set the [Accept data from Ultima exp] off first, and set it on again before pushing the [To BV_Ana] button.

● When transferring data that has more than 8192 frames, save data in a file from Ultima acquisition software once, and then load data into BV_Ana.

● When data that has too many frames is transferred, or many data are transferred in short period, error about data reception may occur due to lack of memory space for BV_Ana.
In this case, close error message, then set the [Accept data from Ultima exp] on BV_Ana OFF.
Ultima acquisition software shows similar error message, so push the [OK] button.
Delete data on the canvas window of BV_Ana, set the [Accept data from Ultima exp] ON again before trying transferring data from Ultima acquisition software to BV_Ana.

● If the [Auto Reference(for CDS/FPN mode)] is selected on the [File List] page of BV_Ana, differential values are automatically calculated when data (acqured with FPN/CDS mode) is transffered to BV_Ana. After calculation, history is added in the [Calculation history] area on the [Calculation] page.
When data which has more than 8,192 frames is transferred to BV_Ana, this calculation is not processed even if data is acquired with FPN/CDS mode due to lack of memory space. After receiving data in BV_Ana, calculate reference and differential values by yourself if needed.