Release Note for BV_Ana Ver.1108

Updates from Ver.1101

1. Additions in Analysis Functions - Available for MiCAM ULTIMA, MiCAM02, MiCAM01 data

1-1 Improvement of function for making averaged data from multiple raw data An averaged data file can be created from multple raw data in offline mode. This can be done on the [Utility]-[averaging] from the main menu.

(1) In the previous version, newly created data keeps averaged values, that can be made by dividing sum of differential values by averaging times. This method was possible to make round-off errors. From this version, new created data keeps sum of differential values and number of added files as averaging times separately to prevent from round-off errors.

(2) New function for sorting list of data file by data file name with [▲][▼].
1-2 Sorting list of data folders and data files by descending order of last updated time The [sort by date modified] checkboxes were added in the [Folder] area and the [File List] area on the [File List] tab page. By selecting these checkboxes, list of data folders/files can be sorted by descending order of last updated time.
1-3 Can change default folder for saving exported data. The previous version uses a folder in which MiCAM data are saved when exporting CSV or BMP files. From this version, it is possible to choose either a current folder or a folder in which MiCAM data are saved in the [File]-[Select] on the main menu before exporting CSV or BMP files.
1-4 New function for calculating maximum speeds of changes in differential values on all pixels On the [Analyze]-[dispay window for slope map] from the main menu, maximum speeds of changes in differential values on all pixels and time at which speeds of changes reach maximum can be calculated and mapped respectively.
1-5 New function for importing external analog signal data from a CSV file External analog signal data can be imported from the [import function]-[Analog Wave CSV Import] on the right click pop-up menu.
1-6 New method for division between two data: [Division2(Intensity)] New function [Division2(Intensity)] was added in the [Calculation] tab page. By using this method, absolute intensity values of two data are divided and ratio of absolute intensity values at 0 frames is set to background image data.
1-7 Others and bug fixes (1) [APD ( Multi )] function
① Resolved an issue that the software crashes when data is saved in a CSV file by the [Save APD Map] button.
② Added values using msec units in an outputted CSV file.

(2) [APD ( Single )] function
① Displays averaged value and standard deviation value (msec unit) on the [Histogram] sub window.
② Removed limits of range setting (upper/lower limit) that can be adjusted by vertical bars on the [APD Map] window.

2. Additions in Acquisition Function (Available only for MiCAM02)

2-1 Bug fix (1) Resolved an issue that a folder name for saving data becomes wrong in the [Vertical] mode.

1. Additions in analysis functions - Available for MiCAM ULTIMA, MiCAM02, MiCAM01 data

(1-3) Can change default folder for saving exported data.

● The previous version uses a folder in which MiCAM data are saved when exporting CSV or BMP files from the [Export Function] on the right click pop-up menu or the [Save CSV] button on some windows. From this version, it is possible to choose either a current folder or a folder in which MiCAM data are saved.

● This selection can be done on the [File]-[User Select] window. The [User Select] Box can appears as below.

● Choose either option for saving exported data.
[in the same folder as the original data]: saves data in a folder in which original MiCAM data are saved (This is as usual).

[Current Folder (in the same folder as saved before)]: saves data in a folder which CSV or BMP files are saved at a previous time.

After choosing either radiobutton, push the [Apply] button.

● When creating "new user", choose either radiobutton similarly in the [New User] area.

● After this setting, specified folder is used as default when saving CSV/BMP files from the [Export Function] pop-up menu and CSV files from the [Save CSV] button on some windows.


(1-4) New function for calculating maximum speeds of changes in differential values on all pixels

● By selecting [Analyze]-[Display Window for Slope Map] from the main menu, two windows ([Show Slope Map Control], [Slope Map]) are shown as below.


● The [Show Slope Map Control] window can show two waveforms on two pixels as reference points. The vertical red dotted line on each wave indicate time (frame position) at which speed of change in differential values becomes maximum.

----
V(x,y,t): differential value at time t and on pixel (x,y)
S(x,y,t): speed of change in differential value
----

S(x,y,t) can be indicated by below calculation formulas
S(x,y,t) = (V(x,y, t+1) - V( x,y, t-1))/(2*sampling time)
(only in the case that V(x,y, t+1) is over specified threshold.)

Maximum S(x,y,t) is defined as Smax(x,y)
On (A) area, calculation formulas for Smax(x,y) can be shown with actual values.

●①[Wave Gain] bar: Can set vertical gain for two waveforms on (A) area.
②[Threshold] bar: Can set threshold value for specifying range of calculation. After changing threshold value, push the [Recalc & Redraw] button.

●A map shows maximum speed (Smax (x,y)) and time at which speed becomes max with color for all of valid pixels.
③Pushing the [Recalc & Redraw ] button refreshes/redraws waveforms and maps with specified threshold level.

Selecting the checkboxes in the [Slope Map Option] area reflects the settings immediately in a map.
④Turning on the [Contour line] checkbox makes contour lines on a map.

⑤Selecting the [Cursor On] checkbox shows two square cursors indicating observation points with black and red color on a map.

⑥Turning off the [Color] checkbox draws a map with 256 level of white to black gradation.
Turning on the [Color] checkbox draws a map with 256 level of color gradation. Color gradation table used for mapping data on the main canvas is used for default color gradation of this map. ⑦Pushing the [Load CSV File] button opens a sub window for selecting other CSV file including color gradation information.

[Zoom] listbox can change zoom magnification of a map image.

[Save Slope Map] button saves a created map image. In case that file extention is bmp/jpg: map image can be saved.
In case that file extention is csv: Numerical values used for drawing a map can be saved with a CSV format.
----
[dF/dTmax] : Value of maximum speed
[(dF/dTmax) frm] : Frame number at which speed is maximum
----
[Fluorescence at (dF/dTmax+1) frm] : Differential value at (Frame number at which speed is maximum)-1) frame
[Fluorescence at (dF/dTmax-1) frm] : Differential value at (Frame number at which speed is maximum)+1) frame
Maximum speeds are calculated from these two values.
----

●⑩By pushing [Canvas setting reload] button, gain settings on the [Control] tab page and settings of [Start]/[End] frames in the [Time&Movie Control] area can be reflected in a map image.

●By moving a mouse cursor on a map, value of a pixel under a mouse cursor can be displayed using a pop-up hint.


(1-5) New function for importing external analog signal data from a CSV file

●After selecting data on the main canvas, select the [Import Function]-[Analog wave csv file import] from right click pop-up menu.
After selecting an importing CSV file on the [File Open] window, the window below appears.

●Input/select parameters about importing CSV file.
① Sampling time (msec) of external analog signals
② Frame number (number of data)
③ Number of channels
④ First row number of signal data
⑤ First column number of signal data

If an importing CSV file has the following format,
③Number of channels = 2
④First row number of signal data = 3
⑤First column number of signal data = 2

(ATTN1) A file that can be imported as external analog signals has to have the format that plural rows are aligned in time sequential order, similar to the above sample image.
The valid numerical values are +/- 16000 integers. Scale actual values in suitable range.

(ATTN2) If an importing CSV file has been opened by Excel, "File Open Error!" message will appear because an Excel occupies the CSV file.

(ATTN3) This function copies original data and create another new data, and then imports analog signal data into the newly created data to prevent from overwrting original analog signal data. Save the new created data into a PC.

(ATTN4) There is no limit for number of imported channels. The [All disp] checkbox was added on the [External Wave Display] subwindow from the right click pop-up menu. When the checkbox is selected, waveforms from all analog channels can be drawn on the main canvas.


(1-6) New method for division between two data: [Division2(Intensity)]

●The [ Division2(Intensity) ] divides absolute intensity values between two data. Before executing, either [overwrite] or [new create] radiobutton should be selected.

●The followings are algorithm for processing data.
D1(t,x,y): differential values of data1
B1(x,y): values of background image of data1
D2(t,x,y): differential values of data2
B2(x,y): values of background image of data2

β: parameter specified by user
D3(t,x,y): differential values of new data3
B3(x,y): values of background image of new data3

B3( t, x, y ) = β*( D1(0, x, y )+B1( x,y ) )*1000/( D2( 0, x, y)+B2( x, y ) )
D3( t, x, y ) = β*( D1( t, x, y )+B1( x,y ) )*1000/( D2( t, x, y)+B2( x, y ) ) - B3( x, y )

Ratio of absolute intensity values at 0 frames is set to background image data.
Since numerical data type of differential values/background image values is integer type, each value are multiplied by 1000 in order to keep significant figure.