Release Note for BV_Ana Ver.1201

Updates from Ver.1108

1. Additions in analysis functions - Available for MiCAM ULTIMA, MiCAM02, MiCAM01 data

1-1 Renewal of the [Stripe Map] function The [Stripe Map] function of the [Display window for stripe] was changed as below.
・ Zoom-in/zoom-out and change in aspect ratio are available for a stripe map.
・ The [Spatial-Filter] funciton was added to the [display wave chart]. This allows the user to display spatially filtered waveform.
1-2 Renewal of the [3D show] map function and new function to display waveform From this version, zoom-in/zoom-out, display of waveform/cursor point are available for 3D map.
1-3 Calculation ratio of change in light intensity using log scale. New [Log Scale] button was added on the [Calculation] page. This button allows to calculate ratio of change in light intensity with log scale and create new data.
1-4 New function to set threshold level by using real light intensity and create new data (this is only for data that shows "real" image). The [Extract by Intensity] was newly added in the pop-up menu. This function is valid only for real mode data. In real mode (when the [real] checkbox is selected on the [Control] tab page), pixels that have lower light intensities than specified threshold level are set to "0" and displayed in black.
1-5 Improvement of the [Change data size & frame] function Until last version, original data is overwritten with new pixel number, new frame number or new sampling time. From this version, original data is not overwritten, but new data is created.
1-6 Others & Bug fixes (1) Fix of cursor size on waveform
Until last version, size of circle and rectangle was 1 pixel smaller than that set by wave-filter on the [Control] tab page.

(2) Modification for a process to save a canvas image from the [File]-[Canvas Image Save As...] menu.
Two dialog boxes are displayed for saving a canvas image. One is for setting folder/file name, and the other is for selecting saved pages.

2. Additions in Acquisition Function (Available only for MiCAM02)

2-1 New function to save histories of operations on the [Acquisition] tab page. [Log Start] button and [Log Stop] button were newly added on the [Acquisition] tab page. The [Log Start] button allows to continue saving histories of operations in a log file until the [Log Stop] button is pushed. Records in a log file can be used as commands for a sequencer function.
2-2 [Delay] time setting for digital output by frame number [delay set in frame] checkbox was added in the [Digital Output] area on the [Acquisition] page.
With this checkbox ON, numerical value in the [delay] textbox is regarded as frame number. (Sampling time per fame x frame number) is used as delay time from start of data acquisition
With this checkbox OFF, numerical value in the [delay] textbox is regarded as time as well as previous version.
2-3 New mode to output page number from digital I/O port User can select new mode (4: Page Number) from the listbox on the [MC02 Setting Option] subwindow. When [Seq. Multi] or [Random Multi] is selected from the [Page Mode] listbox on the [Acquisition] tab page, this new mode allow to output page number from digital I/O port on rear panel of MiCAM02 processor.
2-4 Bug Fixes Resolved a problem of one frame delay in display of external analog wave when using [Preview2] function on the [Acquisition] window.

1. Additions in analysis functions - Available for MiCAM ULTIMA, MiCAM02, MiCAM01 data

(1-1) Renewal of the [stripe] map function

● The [stripe] map function can be executed by selecting the [Analyze]-[Display Window for Stripe] from the main menu, or pushing the button on the tool bar.
Operations on the [Stripe Map] subwindow, which can be opened by pushing [Map Draw] button ① on the [Show Stripe Main] window, were changed in this version.
Basic functions are same as previous versions.


②Frame range selected in the [Frame Setting] are used for X-axis of map image.
Until last version, X-axis is displayed with some frames skipped. From this version, all frames in a selected range are used for X-axis. Map image may appear to be collapsed, depenging on size of display,

③ [Y-axis rot] Strip map rotates on Y-axis.

④ [X-axis rot] Strip map rotates on X-axis.

⑤ [zoom] Zoom-in by [near] and zoom-out by [far]

⑥ [size aspect] changes aspect ratio (X:Y=time:pixel)

(ATTENTION)
The format of ".set" file, which can be saved by the [Setup Save] button and loaded by [Setup Load] button, was changed in this version. This ".set" file contains setting information for [Stripe Main] window, therefore please note that old ".set" file saved in previous version can not be loaded on BV_Ana that will be released from 1112 or later.

● New function of [Spatial-Filter] was added on subwindow that can be displayed by selecting [display wave chart at a frame(time)] checkbox on the [Stripe Map] subwindow.
This works in the same way as that in the [Calculation] tab page. Parameters are selectable from [3x3][5x5][7x7][9x9][11x11][4x4]. If [3x3] is selected, differential value on center of 9 (3x3) pixels is replaced with an averaged differential value.


(1-2) Renewal of the [3D show] map function and new function for wave display

● The [3D show] map can be opened by selecting the [Analyze]-[Display Window for 3D] menu or pushing the button on the tool bar.
New [3D show] map window has 3D image and a waveform. A point (pixel) on which waveform is displayed is indicated with blue line.
A default position of blue line is same as a position that first waveform on data of canvas window is indicating. If no waveform is displayed on canvas, center of image is used as default position.

① rotates 3D image on Y-axis.

② rotates 3D image on X-axis.

③ zooms in/zooms out 3D image. Zoom-in by [near] and zoom-out by [far]

④ switches a color bar ON/OFF.

⑤ switches waveform display ON/OFF on an exported BMP image or AVI movie.

⑥ updates 3D image display after settings on the [Control] tab page are changed.

⑦⑧ [▲][▼] buttons change position of pixel.

⑨ allows for the user to change pixel position after XY coordinates are manually inputted.

⑩ switches a cursor (blue) line ON/OFF on 3D image.

⑪ changes wave gain.



(1-3) Calculation of ratio of change in light intensity using log scale

● New [Log Scale] button was added on the [Calculation] page. This button allows to calculate ratio of change in light intensity with log scale and create new data.

<< How to Calculate >>

Assuming that a parameter value inputted in the textbox next to the [Log Scale] button is "prm",

When diffential value on pixel(x,y) is D(x,y) and background value on pixel(x,y) is F(x,y),
ratio of change in light intensity is regarded as V(x,y)=(D(x,y)/F(x,y) )
D'(x,y) = log10( V(x,y) * prm )
In case of D'(x,y) < 0, D'(x,y) = 0
In case of D(x,y) < 0, D'(x,y) = -D'(x,y)
D_new(x,y) = D'(x,y)*100

Since D_new(x,y) is integer type, D_new(x,y) is calculted by centuplicating D'(x,y) so that D_new can keep significant digit.

● "100" is set to background value on all pixels. A background image can be changed by [Substitute Back Image] on the pop-up menu.

(1-4) New function to set threshold level by using real light intensity and create new data (this is only for data that shows "real" image)

● After selecting data on the canvas window, execute the [Extract by Intensity] on the pop-up menu. The [Extract by Intensity] window will appear as below. The image displayed on this window is in "real" (with the [real] checkbox ON) mode.

① indicates light intensity values (background value + differential value) on two points (pixels) at a selected frame. By dragging green and orange cursors, positions of two points can be changed.

② changes gain of waveform.


③ Input light intensity value that should be used as threshold level. After value is manually inputted, push the [Set] button to update. ④ slide bars allow to change value on each of 4 digit.

⑤ After setting threshold, push the [Create new data] button in order to create new data on the canvas window.

When (background value + differential value) < threshold,
new differential value =-(background value).

Then, (background value + differential value) is set to "0" and
this pixels is displayed in black.


2. Additions in Acquisition Function (Available only for MiCAM02)

(2-1) New function to save histories of operations on the [Acquisition] tab page

● This new function is to record settings/operations on the [Acquisition] tab page into a log file.

● At first, push the [Log Start] button on the [Acquisition] tab page.
Select a folder for saving and input a log file name on the [Save As...] window.
(Current date is used for a default file name. This can be changed manually if needed.)
BV_Ana starts to record operations after a file name is specified.

● To stop recording, push the [Log Stop] button. Histories of operations after the [Log Start] button is pushed can be saved in one file until the [Log Stop] button.

● Records in a log file can be used as commands for a sequencer function.
A log file can be loaded from the [Load] button on the [Auto Exec by sequencer] window, which is opened with the [Auto Exec] button. After selecting ".log" as file extention and specifying a log file, commands in a log file are loaded in a sequencer function. Those commands in a sequencer can be edit manually if needed.

<<< An example of log file >>>

##20111107_155317.log Log Start...;
camera_size = 1;
sampling = 2.2;
page_mode = 0;
acqs;
save_data;
## Log End;


(2-2)[Delay] time setting for digital output by frame number

● Until previous version, "delay" in the [Digital Output] area on the [Acquisition] tab page could be specified by time (msec or sec). From this version, with the [delay set in frame] checkbox ON, numerical value in the [delay] textbox is regarded as number of frames. (Sampling time per frame x frame number) is used as delay time from start of acquisition
With the [delay set in frame] checkbox OFF, numerical value in the [delay] textbox is regarded as time as well as previous version.



(2-3) New mode to output page number from digital I/O port

● When [Seq. Multi] or [Random Multi] is selected from [Page Mode] listbox on [Acquisition] tab page, MiCAM02 acquires specified number of data.
If new mode (4: Page Number) from the listbox on the [MC02 Setting Option] subwindow is selected, MiCAM02 processor can output signal of page number from digital I/O port on rear panel.

● Page number is outputted from 5 of pins (7,3,8,4,9) of D-SUB9 on the repar panel. 7 pin: least significant bit, 9 pin: most significant bit. From 0 to 31 can be outputted as page number.