Release Note for BV_Ana Ver.1604

Updates from Ver.1508
This version is adapted to Windows 64-bit OS only.

1. Additions in Analysis Functions - Available for MiCAM ULTIMA, MiCAM02, MiCAM01 data

1-1 New functions for Multi APD Map New functions were added in [Analyze]-[Display Window for APD (multi heart beat)].
・ Averaged value in ROI (region of interest) can be used for APD analysis.
・ Method of calculation for BPM was modified. Values between two peaks are sorted out and values except maximum and minimum values were averaged.
・ Fixed a bug that calculated value are changed after pushing [Recalc] button.
1-2 TRize Map Function [Analyze]-[Display Window for TRise Map] was modified, similarly to [Display Window for APD (multi heart beat)].
・ Method of calculation for BPM was modified.
・ Values between two peaks are sorted out and values except maximum and minimum values were averaged.
1-3 Stripe Map Function [Analyze]-[Display Window for Stripe Map] was modified.
・ 2D display was added (2D display means that "Z" value (distance) for 3D display is 0).
・ [Image Point] 1/2/3 is available when [Wave Display] is selected.
・ Fixed a bug that range of frames in [Frame Setting] is not changed when [Wave Display] is selected.
1-4 Bug fixes and others ・ Checks if [Data Folder], which can be specified on [File]-[User select], already exists.
If a folder does not exist, a message window to ask user to create new folder is displayed when BV_Ana is started up.

2. Additions in Data Acquisition Function (Available only for MiCAM02)

2-1 Automatic correction of aspect ratio for image acquired with [High Resolution] camera ・ [auto resize of HR camera] checkbox was added on the [Acquisition] windows.
This checkbox is enabled when [HR (High Resolution)] camera is selected.
When this checkbox is ON, acquired data is automatically corrected 1.166 times in the Y -axis direction.
2-2 Bug fixes and others ・ Fixed a bug that an error occurs when [average] times is more than 64 when [+each data] is ON.

1. Additions in Analysis Functions

(1-1)New Functions for Multi APD Map

・ Shape of ROI (region of interest) can be saved from [Save pt] button on the [Analyze]-[DispLay Window for Wave of ROI/Line].

・ Select [Analyze]-[Display Window for APD (multi heart beat)] from the main menu and then, the following window is displayed.

・ Load a csv file, which was saved from [DispLay Window for Wave of ROI/Line], by clicking the [Load pt] button.
APD analysis can be done by using averaged value among values in ROI.

・ After setting such as "Threshold" is changed, click the [Recalc&Redraw APD Map] button.
To return setting to initial values, click [Canvas setting reload] button.

(ATTN)
"APD Multi Map" is not changed. APD map is created only for pixels which is specified before opening [Display Window for APD (multi heart beat)] window.
First ROI included in a CSV file saved from [Load pt] is used for this function.


(1-3) Stripe Map Function

The following new functions were added for [Wave Display] mode.

・ When [1]/[2]/[3] checkboxes in [Image Point] area are clicked, specified waveforms are displayed on wave display (B). These waveforms show activities on image pixels.

Only when [3D Display] is selected, it is possible to change "image point" by mouse-dragging horizontal dotted lines on strip map.



(2-1) Automatic correction of aspect ratio for image acquired with [High Resolution] camera

・ This function is available only when "HR [High Resolution]" camera is used.
When this checkbox is ON, acquired data is automatically corrected 1.166 times in the Y -axis direction and displayed on the canvas windows. Original data (without correction pf ascpect ratio) is not displayed, but automatically saved in a file.

・ To use this function, click the [auto resize of HR camera] checkbox on the [Acquisition] window, and then start data acquisition.